Slow Response Times

Incident Report for Degreed

Resolved

Our team has resolved our slow response times and Degreed is now operating normally.
Posted Sep 22, 2023 - 05:32 UTC

Identified

Our teams have identified the cause of the slow response times. We're currently working to restore response times back to normal.
Posted Sep 22, 2023 - 05:18 UTC
This incident affected: Degreed US (Degreed Web).