Incident Notice: Degreed Loading Issue

Incident Report for Degreed

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 22:31 UTC

Update

We’re observing signs of improvement across regions, though the service has not yet fully stabilized. The Azure team is still actively mitigating the issue, and our teams continue to monitor performance closely. We’ll share further updates as the situation evolves.
Posted Oct 29, 2025 - 20:48 UTC

Update

It has been confirmed that the website loading issue is due to an outage in Microsoft Azure. Our team is monitoring the situation closely. We will provide further updates as soon as more information is available.
Posted Oct 29, 2025 - 16:42 UTC

Update

It has been confirmed that the website loading issue is due to an outage in Microsoft Azure. Our team is monitoring the situation closely. We will provide further updates as soon as more information is available.
Posted Oct 29, 2025 - 16:37 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 29, 2025 - 16:36 UTC

Identified

It has been confirmed that the website loading issue is due to an outage in Microsoft Azure. Our team is monitoring the situation closely. We will provide further updates as soon as more information is available.
Posted Oct 29, 2025 - 16:27 UTC

Investigating

We’re aware that some users are currently experiencing issues accessing our website. Our initial investigation points to a Microsoft Azure–related service disruption affecting parts of our infrastructure.
Posted Oct 29, 2025 - 16:19 UTC
This incident affected: Degreed US (Degreed Web, Academies (ACM)), Degreed EU (Degreed Web, Academies (ACM)), and Degreed CA (Degreed Web).