Site Slowness - US Region

Incident Report for Degreed

Resolved

Service has been restored. This incident is now closed.
Posted Sep 21, 2026 - 14:41 UTC

Investigating

We are currently investigating an issue affecting load times on the platform. Users may experience slower-than-normal loading times across the site.
Posted Sep 21, 2026 - 14:36 UTC
This incident affected: Degreed US (Degreed Web).