Sitewide slowness - EU region

Incident Report for Degreed

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 11:40 UTC

Investigating

We are experiencing sitewide slowness in the EU region and we are actively investigating the cause.
Posted Sep 16, 2026 - 10:50 UTC
This incident affected: Degreed EU (Degreed Web).