Content catalog (end user, admin) are not loading

Incident Report for Degreed

Resolved

Resolved: The issue has been fully resolved, and all systems are now operating normally.
Posted Nov 03, 2025 - 17:56 UTC

Update

We are continuing to investigate this issue.
Posted Nov 03, 2025 - 17:05 UTC

Investigating

We're currently experiencing issues where the content catalogue (end user, admin) isn't loading as expected in the UI. Our teams are currently investing.
Posted Nov 03, 2025 - 15:08 UTC
This incident affected: Degreed US (Degreed Web).